Author Topic: Bricked my MX2? Please help.  (Read 1423 times)

Offline skeptic

  • Baby Member
  • *
  • Posts: 42
  • Points: 0
    • View Profile
Bricked my MX2? Please help.
« on: September 29, 2013, 08:12:24 PM »
Got my MX2 Friday, today I decided to do the manual upgrade to 1.1.6.  Found an SD card, put the updgrade files from the zip file on the SD card, and verified the MX2 could mount the SD card.  So far so good.  Powered off and unplugged the MX2, put the SD card in, held down the A/V button and plugged it in.  When the screen got to where it was updating the system I let off the A/V button and sat back to watch it.  After a while I was greeted with an unspecified script error and an Android recovery screen with options like reboot, update from this or that..  I chose reboot.  At that point it booted into Android, and took me through the initial setup.  Unfortunately no XBMC, and probably other missing apps. Checking the OTA update app showed me 1.1.6, and some kind of firmware doesn't match hardware error. Trying to click XBMC immediately came back with download error.  Sooooo, at that point I decided to give the firmware install another shot.  Powered off, "toothpick" in place, plug box in - nothing, blank screen.  Not sure what was going on so I held the A/V button down for about a minute, nothing ever came on-screen.  At this point I have not found any way to get any kind of display back.  SD card in or out, A/V button pushed or not, power cycle with the remote or unplug/plug in..  I pulled out the 2 bluetooth dongles I was using (keyboard and mouse), no help.

I did find a link describing how to recover from this, but it appears to be for the Midnight box, not the Midnight MX2.  Is there anything I can do at this point to unbrick my MX2?
« Last Edit: September 29, 2013, 08:12:24 PM by skeptic »

Offline BocaApps

  • Hero Member
  • *****
  • Posts: 547
  • Points: 48
  • The Real Deal
    • View Profile
Bricked my MX2? Please help.
« Reply #1 on: September 29, 2013, 08:36:38 PM »
Start from scratch see if it works. Should have waited for ota .The firmware doesn\'t match hardware error is normal since it wasn\'t ota done. when you had it with no xbmc you were ok you just go to ota and download xbmc. Also bluetooth is not set up yet. 
Matricom Authorize Reseller

Offline skeptic

  • Baby Member
  • *
  • Posts: 42
  • Points: 0
    • View Profile
Bricked my MX2? Please help.
« Reply #2 on: September 29, 2013, 09:21:40 PM »
Well, I\'m trying to start from scratch but no luck yet.  Honestly, I\'m not sure I know what \"start from scratch\" means.  I agree, I should have waited for OTA.  Unfortunately the current version of XBMC on the MX2 has a couple bugs which kinda kills MythTV PVR use for me and destroys any wife acceptance factor.  I saw a note that 1.1.6 has an upgraded XBMC and that suckered me in.  Plus, being the weekend I actually have a little time to mess with it.

I thought maybe I was ok after the first errors as it did reboot, but but when I tried to download XBMC from OTA it immediately errored out.  For what it\'s worth, I just tried this recovery method: http://matricom.net/forum/discussion/2/how-to-recover-your-mx2-when-it-wont-boot-past-the-matricom-screen-/p1 even though my symptoms don\'t quite match.  It doesn\'t require selecting anything onscreen, just patience.  In my case just giving it far more time than what you should see on screen and a fix for just the bootloader.  Didn\'t work.

At this point seeing ANYTHING onscreen would be a step forward.

Offline rickyd1982

  • Newbie
  • *
  • Posts: 9
  • Points: 0
    • View Profile
Bricked my MX2? Please help.
« Reply #3 on: September 29, 2013, 09:27:47 PM »
Same. Here blank screen

Offline skeptic

  • Baby Member
  • *
  • Posts: 42
  • Points: 0
    • View Profile
Bricked my MX2? Please help.
« Reply #4 on: September 29, 2013, 09:42:16 PM »
Not sure why that makes me feel better, but at least I\'m not the only one.  Did you get to the blank screen the same way I did?  Failed 1.1.6 upgrade?  

Assuming the same MX2 hardware and same firmware, we might be able to find a pattern..  I did the upgrade from an old 8G SD card, and looking at it now I see it\'s formatted as FAT not FAT32.  I also had a couple usb dongles plugged in, one for a logitec mouse and one for the Motorola Nyxboard.  I had the ethernet plugged in as well as I try to avoid wifi for my media players.  I can\'t think of anything else that could be different from others.
« Last Edit: September 29, 2013, 09:43:03 PM by skeptic »

Offline P0ida

  • Sr. Member
  • ****
  • Posts: 455
  • Points: 0
    • View Profile
Bricked my MX2? Please help.
« Reply #5 on: September 29, 2013, 09:44:28 PM »
@skeptic I had a similar scare after installing this and then trying to return to Linux (everything failed to install with an \'unspecified error\')
What fixed it for me was running the mx2-boot-recovery.zip and then reinstalling 1.1.5 F/W.

After that, everything was back to normal ;)

Offline rickyd1982

  • Newbie
  • *
  • Posts: 9
  • Points: 0
    • View Profile
Bricked my MX2? Please help.
« Reply #6 on: September 29, 2013, 09:51:39 PM »
I got the error msg when i tried to download xbmc aswell but before that i used the miracast app on it and was able to Paul my nexus 7 on it worked perfect put in the bluetooth dongle tried it so all i had was a bluetooh dongle and wired mouse tried to download xbmc got the error msg so i thought maybe just needs turned off and back on again turned it off and on no. Screen

Offline skeptic

  • Baby Member
  • *
  • Posts: 42
  • Points: 0
    • View Profile
Bricked my MX2? Please help.
« Reply #7 on: September 29, 2013, 11:05:19 PM »
You guys are giving me hope that I can fix it without boxing it up and sending it off to Matricom.  I did try the boot-recovery, but that didn\'t work.  To be fair, it was not on a freshly formatted SD card, it was a FAT formatted card that had a DCIM directory (from a camera) and I just put the recovery files on it.  

Help me understand what I should see, from what I can tell this should be my procedure:
Format the SD card as FAT32
Open the recovery zip and copy recovery.img and u-boot.bin to the card
insert the card, hold down the reset switch, plug in the MX2
continue to hold down the reset button for a 20 count (since I just have a blank screen)
let up the reset switch and let the MX2 sit and run for another minute (assuming still a blank screen)
unplug the MX2, pull the SD card, then try to boot it

Is this right?  Should this get me to a point where I can try to manually install the 1.1.6 firmware?  Other than formatting the SD card which still has a DCIM directory, this is the procedure I did already and I still get a blank screen.

Should I then follow the same steps but this time with a 1.1.6 firmware?  Until I get some kind of display on the screen I\'m lost on what is going on or what I should do next.

Offline BocaApps

  • Hero Member
  • *****
  • Posts: 547
  • Points: 48
  • The Real Deal
    • View Profile
Bricked my MX2? Please help.
« Reply #8 on: September 29, 2013, 11:49:33 PM »
Don\'t put sd card in power off box unplug power hold button in and plug box in .hold till you get a menu . now add your sd card in with 116 firmware on it and use the menu to hilight mx software let run do not stop it it will load android for about 5 min.

Also where did you buy box from
« Last Edit: September 29, 2013, 11:51:28 PM by BocaApps »
Matricom Authorize Reseller

Offline BocaApps

  • Hero Member
  • *****
  • Posts: 547
  • Points: 48
  • The Real Deal
    • View Profile
Bricked my MX2? Please help.
« Reply #9 on: September 30, 2013, 12:03:23 AM »
@P0ida how were you able to drop down to 115 ?
Matricom Authorize Reseller

Offline P0ida

  • Sr. Member
  • ****
  • Posts: 455
  • Points: 0
    • View Profile
Bricked my MX2? Please help.
« Reply #10 on: September 30, 2013, 12:38:41 AM »
@skeptic Once the recovery is done you will be at the recovery screen. Replace the boot-recovery files on SDcard with F/W, replace and do the toothpick reboot again.

@
BocaApps As per the above. (I put 1.1.5 F/W on the SDcard)
« Last Edit: September 30, 2013, 12:39:52 AM by P0ida »

Offline skeptic

  • Baby Member
  • *
  • Posts: 42
  • Points: 0
    • View Profile
Bricked my MX2? Please help.
« Reply #11 on: September 30, 2013, 01:39:58 AM »
No menu comes up, SD card out, reset button held in, plugged box in, held for about 90 seconds - nada.  

Then I tried what I listed above - freshly formatted SD card, recovery files only.  Hold down button, SD card in, plug in power - hold for 20 seconds then let up.  Let sit 1 minute (supposed to be 10 seconds with button down, then ~12 seconds for the fix).

Tried again, no SD card, button down, plug in - held for about a minute and still blank screen.

Removed recovery files from SD card, put Firmware 1.1.6 files on SD card, inserted card, held down reset button, plugged in.  I was completely shocked after 10 seconds or so when the screen popped on and I saw the droid updating screen!  OTA Updater still (again) gives me invalid ROM & device combo! but apparently that is to be expected until the firmware shows up in OTA Updater.  The most disappointing part of all is XBMC is still at 12.0 and the myth PVR client is still at 1.6.7 - the XBMC bugs that really kill PVR for me are still there.

At least I\'m back to a fresh install MX2, even if I have to set everything up again and I probably will not even use it until XBMC/PVR client has an upgrade available.  Perhaps I\'ll try to find a non Matricom version that supports hardware decoding AND is a more current release.  Various bits of XBMC seem to be doing upgrades, so I\'m going to let it run for now and just see if PVR updates will become available.  


For anyone else who runs into this, I can\'t really pinpoint what the issue was, maybe just bad luck?  What I can say is everything I did to get me back to a working box I documented above.  When I got it fixed I didn\'t have anything plugged in other than power, HDMI and the SD card.  No ethernet, no USB dongles for mouse/keyboard, nothing.  Hopefully this helps someone.

Offline rickyd1982

  • Newbie
  • *
  • Posts: 9
  • Points: 0
    • View Profile
Bricked my MX2? Please help.
« Reply #12 on: September 30, 2013, 08:14:30 AM »
Happy days glad u got it going again was up till 4 in the morning tryining to fix it with no. Joy ill try ur method now thanx

Offline skeptic

  • Baby Member
  • *
  • Posts: 42
  • Points: 0
    • View Profile
Bricked my MX2? Please help.
« Reply #13 on: September 30, 2013, 09:14:29 AM »
Good luck!  Please post up how it goes.  That way so our pain may help others.

Offline DEVilishWAY

  • Jr. Member
  • **
  • Posts: 72
  • Points: 2
    • View Profile
Bricked my MX2? Please help.
« Reply #14 on: September 30, 2013, 11:02:30 AM »
What I am more concerned with is why didn\'t the firmware auto-install for you guys. Not being able to download it from the OTA app is usual as I did not update the links yet (will do so in a few minutes). If I am correct I saw 2 people state they flashed and notice that XBMC was not installed, how about any of the other data apps?  That is a major concern and I would like to get to the bottom of that quickly. More information appreciated.